Monday, November 26, 2007

AIX Commands For The Solaris User

If you use Solaris and/or most major Linux distros, AIX administration can be a bit unsettling to jump right into. Luckily, they do include a nice VT interface to get almost anything done called "smitty." You can also call it from the command line as "smit."

Since I have to work on AIX, I thought I'd write a quick listing of the more common commands I use in AIX (that differ the most from Solaris) and what they're used for. Since the list is a bit long, it'll be the meat of this post:

errpt -a (Generates a report of logged errors)
cpu_state -l (Reports on the status of the system CPU(s))
lsattr -HE -l sys0 -a realmem (Shows the amount of usable physical memory)
lsattr -El sys0 | grep realmem (The 2nd column shows the amount of memory recognized by the system, in bytes)
lsdev -Cc memory (Lists all memory cards installed (and sometimes their size, but it's not always correct))
lscfg -vl memX (Where memX is the name of the card; lists the size of memory)
lsdev -Cc adapter (Lists all adapters)
lsdev -Cc disk (Lists all disks)
mount -v cdrfs -o ro /dev/cd0 /cdrom (Mounts the CD-ROM)
mpcfg -df (Displays diagnostic flags/options)
mpcfg -cf 11 1 (Sets the "Fast IPL" (Initial Progam Load) option to ON, to speed up the boot process)
shutdown -Fr (Sets fast shutdown and reboot)
lsps -s (Shows swap space amount and usage)
instfix -a (Lists O/S patches)
instfix -ivk APAR_NUMBER (Lists O/S patches installed - Usage example: instfix -ivk IX75866)
instfix -ik | grep ML (Lists O/S installed patch versions and their status)
instfix -icqk 4330-09_AIX_ML | grep ":-:" (One way to report what filesets are missing from a certian maintenance level)
lslpp -l FILESET_NAME (Lists and gives the status of operating filesets installed - Usage example: lslpp -l bos.rte.install)
lslpp -w FILENAME (Reports which fileset a file belongs to - Usage example: lslpp -w /etc/sendmail.cf)
lslpp -l bos.rte (Lists the version of AIX)
oslevel (Displays the O/S level)
bootinfo -r (Displays the amount of real memory in Kb)
bootinfo -K (Shows if you're running a 64 or 32 Bit O/S)
no -a (Reports current network attributes and their settings)
netstat -v interface (Reports network statistics and network speed)
lppchk -v (Verifies that all installed software is actually installed. Also verifies that it's installed correctly)
lppchk -m3 -v (Displays verification report of installed software with tons of detail)

Most everything else is very similar and should be easy to pick up. In a future post we'll look as some HP-UX commands that differ from Solaris and major Linux distro's like RedHat.

In the meantime, if you're a Solaris admin and get stuck working on an AIX box, hopefully this little list will make your life easier :)

, Mike